Statistics reports not showing latest data

Incident Report for Gorgias

Resolved

All data has been processed and statistics are now up-to-date
Posted Feb 07, 2025 - 23:12 PST

Investigating

We are currently investigating this issue.
Posted Feb 07, 2025 - 18:10 PST
This incident affected: Helpdesk Clusters (us-east1-635c) and Helpdesk (Web App).