europe-west3 — Stale views data and missing ticket counts

Incident Report for Gorgias

Monitoring

We have mitigated the issue affecting views in the europe-west3 cluster. Ticket counts and view data should now be updating, however performance is still degraded and updates may take longer than usual. We are monitoring the situation and will deploy a definitive fix to fully resolve the issue.
Posted Jun 25, 2026 - 09:02 UTC

Update

We are continuing to investigate this issue.
Posted Jun 25, 2026 - 08:44 UTC

Investigating

Customers in the europe-west3 cluster may experience stale data in their views — including incorrect or missing ticket counts. Other regions are not impacted. Our team is actively working on a fix and will provide an update once resolved.
Posted Jun 25, 2026 - 08:26 UTC
This incident affects: Helpdesk (Web App).