Some customers may not be able to start new Email Domain verifications, because of an issue with our provider
Incident Report for Gorgias
Resolved
We're in contact with our provider to make sure the issue is solved as soon as possible. In the meantime, should you experience this issue reach out to support to implement a workaround
Posted Jul 06, 2023 - 10:36 PDT
Identified
Some of our customers may receive a `Something went wrong with domain registration service: "Domain quota exceeded for the account"` error when they try to add a new email domain.

We've reached out to our email services provider to see if we can get this quota increased.
Posted Jul 04, 2023 - 10:14 PDT
This incident affected: Helpdesk Integrations (Email).