The signup page is not responding
Incident Report for
Gorgias
Resolved
The third party outage is now over and the situation is back to normal.
Posted
Oct
20
,
2025
-
17:41
UTC
Monitoring
Due to a third party outage, the signup page
https://www.gorgias.com/signup
is returning errors. We are monitoring the situation.
Posted
Oct
20
,
2025
-
16:45
UTC
×
Subscribe to Incident
Subscribe to updates for
The signup page is not responding
via . You'll receive .