What happened: A network issue affecting part of our infrastructure caused the Helpdesk API and related services to go down. This was triggered by unplanned updates from our cloud provider that led to unexpected network instability. We know this was frustrating and unfortunately outside of your control.
When: Started: 2026-03-09 at 12:30 UTC Mitigated: 2026-03-09 at 15:00 UTC
Impact: During this time, the web app, mobile app, and main Helpdesk API were unavailable. If you tried to access your helpdesk, you would have seen a 502 error. We know how disruptive that can be, and we sincerely apologize for the inconvenience this caused you and your business.
Current status: The issue has been mitigated. We've restored traffic and validated core functionality, and we're continuing to closely monitor things to make sure everything stays stable. We'll share more updates if anything changes.
Posted Mar 09, 2026 - 15:53 UTC
Investigating
We are currently investigating this issue.
Posted Mar 09, 2026 - 13:34 UTC
This incident affected: Helpdesk (REST API, Web App, Mobile Apps) and Helpdesk Clusters (us-central1-c433).