Most of our services have successfully recovered. Our teams are actively monitoring and working to ensure stability and full restoration.
Posted Jun 12, 2025 - 21:45 UTC
Update
We are beginning to see signs of recovery across impacted services. Our teams are actively working to ensure stability and full restoration.
Posted Jun 12, 2025 - 21:13 UTC
Monitoring
We are beginning to see signs of recovery across impacted services. Our teams are actively working to ensure stability and full restoration.
Posted Jun 12, 2025 - 20:30 UTC
Update
We are continuing to work on a fix for this issue.
Posted Jun 12, 2025 - 18:38 UTC
Update
We are continuing to work on a fix for this issue.
Posted Jun 12, 2025 - 18:28 UTC
Identified
One of our cloud providers (Google) is encountering a widespread issue with its services impacting some components in charge of processing new messages, updating stats and search results, leading to delays.
Posted Jun 12, 2025 - 18:19 UTC
This incident affected: Helpdesk Clusters (us-east1-635c, us-east4-65cd, us-east1-2607, aus-southeast1-fcb9, europe-west3-86c1, us-central1-d8ff, us-east4-5f09, europe-west1-c511, us-central1-c433, us-east1-c94b, europe-west4-e7f4) and Helpdesk Integrations (Gmail, Outlook, Facebook Messenger, Native Phone, Instagram Direct Messages, SMS, WhatsApp).