Permission denied errors when trying to send Facebook direct messages
Incident Report for Gorgias
Resolved
We didn't observe any new occurrences since the last update, any problems on Meta's end seem to have been resolved.
Posted Nov 16, 2023 - 03:33 PST
Monitoring
Meta's status page has been updated at 3:28 AM UTC reporting the incident as resolved, however, some customers may have kept experiencing the permission denied error or a new `An unknown Facebook error was returned: OAuthException(-1): (#-1) Unexpected internal error ` one up until at least 4:49:20 AM UTC.

It should be now safe to retry the delivery of any failed messages, we'll keep monitoring and mark this incident as resolved once we have verified there are no other occurrences of this issue.
Posted Nov 16, 2023 - 00:58 PST
Identified
Meta's status page has been updated and now reports an incident affecting their messaging platform, see https://metastatus.com/messenger for more details.

We'll continue to monitor the situation and post an update once we've confirmed that our customers should no longer experiencing this issue.
Posted Nov 15, 2023 - 15:28 PST
Update
When we try to send these messages we get the `(#10) Cannot message users who are not admins, developers or testers of the app until pages_messaging permission is reviewed and the app is live.` error. Our app however is live and doesn't seem to have any problems with that permission on Meta's developers portal.

We reached out to their support as this appears as an issue with their APIs.
Posted Nov 15, 2023 - 14:55 PST
Update
Some of our customers report that they're still experiencing this problem, if that should be the case please do not retry until further notice.
Posted Nov 15, 2023 - 14:10 PST
Investigating
We experienced a temporary problem with permission denied errors from Facebook when sending direct messages between 8:09:02 PM UTC and 9:13:53 PM UTC. This appears to have stopped now, so it should be safe to retry any failed messages. We're currently investigating the causes.
Posted Nov 15, 2023 - 13:32 PST
This incident affected: Helpdesk Integrations (Facebook Messenger).