Increased error rate and delay in processing messages in one region

Incident Report for Gorgias

Resolved

As of 23:30 UTC we caught up with all delayed messages and Shopify integration actions. This issue is resolved.
Posted Jan 17, 2023 - 16:40 PST

Update

We have implemented fixes and restored operation to many features in the us-east4-5f09 cluster as of 21:00 UTC.

However we were still experiencing failures in our Shopify integration as a result of restoration efforts.

Messages and webhooks are delayed for this integration. We have restored operation to the integration but are now processing the backlog that had accumulated.

We appreciate your patience and apologize for any inconvenience this has caused. The root cause has been identified and we will continue to work to resolve this situation.
Posted Jan 17, 2023 - 14:28 PST

Identified

The issue has been identified and a fix is being implemented.
Posted Jan 17, 2023 - 12:00 PST

Update

We are continuing to investigate this issue.
Posted Jan 17, 2023 - 11:35 PST

Investigating

We are currently investigating this issue.
Posted Jan 17, 2023 - 11:34 PST
This incident affected: Helpdesk (REST API), Helpdesk Clusters (us-east4-5f09), and Helpdesk Integrations (Shopify integration).