Datetime Formatting Issue
Incident Report for Gorgias
Resolved
This incident has been resolved.
Posted Oct 10, 2023 - 12:37 PDT
Investigating
We are currently investigating this issue.
Posted Oct 10, 2023 - 10:38 PDT
This incident affected: Helpdesk (Web App).