Stats not loading

Incident Report for Gorgias

Resolved

We issue has been resolved.
Posted Nov 11, 2025 - 16:05 UTC

Monitoring

We are currently investigating this issue.
Posted Nov 11, 2025 - 15:19 UTC

Investigating

We are currently investigating this issue.
Posted Nov 11, 2025 - 15:13 UTC