Account signup form reports errors

Incident Report for Gorgias

Resolved

This incident has been resolved.
Posted Apr 24, 2026 - 15:50 UTC

Monitoring

A fix has been deployed, we are monitoring to ensure continuation of service
Posted Apr 24, 2026 - 15:24 UTC

Investigating

We are currently investigating this issue.
Posted Apr 24, 2026 - 14:58 UTC