Helpdesk general slowness

Incident Report for Gorgias

Resolved

This incident has been resolved.
Posted Jul 01, 2026 - 13:28 UTC

Identified

We're working on deploying a fix
Posted Jul 01, 2026 - 12:37 UTC

Investigating

We are currently investigating this issue.
Posted Jul 01, 2026 - 11:25 UTC