Delay in sending Mailgun emails
Incident Report for Gorgias
Postmortem

Due to a Mailgun outage (our email sending provider), email sending was effectively blocked for a couple of hours on February 21st, slowing down the processing of our worker queues. Rules were severely affected, including actions and basically any functionality that relies on sending emails.

As soon as Mailgun fixed their incident on their side, they started processing their own backlog of emails and our worker queues slowly started to be processed as well.

Posted Feb 24, 2022 - 05:39 PST

Resolved
The incident has been resolved. Functionalities on our side are now working as expected, but delays in receiving emails might still be experienced due to queues on Mailgun's side.
Posted Feb 21, 2022 - 11:49 PST
Monitoring
The incident on our provider's side (Mailgun) seems to be over and we are monitoring the situation.
Posted Feb 21, 2022 - 11:24 PST
Identified
We are experiencing delays sending Mailgun emails (default email integration) and executing some actions (macros, rules, ...).
Posted Feb 21, 2022 - 11:23 PST
This incident affected: Helpdesk Integrations (Email, Mailgun SMTP, Mailgun outbound email, Mailgun API) and Helpdesk Clusters (us-east1-635c, us-east4-65cd, us-east1-2607, aus-southeast1-fcb9, europe-west3-86c1, us-central1-d8ff).