Some Outlook emails are not coming in
Incident Report for Gorgias
Resolved
The issue was resolved and all missed emails have been imported.
Posted Dec 03, 2019 - 08:51 PST
Investigating
Some Outlook / Office365 are currently not receiving emails, or missing some emails. We're currently investigating this issue and will let you know as soon as we have updates.
Posted Dec 02, 2019 - 12:25 PST
This incident affected: Integrations (Outlook integration).