Recent Service Disruptions
Incident Report for Gorgias
Postmortem

Recent Service Stability Updates

At Gorgias, we understand the critical importance of platform reliability, especially with key events like Black Friday approaching. Recently, we’ve experienced some service disruptions that have impacted a portion of our users. We want to assure you that we’re addressing these issues and working hard to enhance the stability and performance of our platform.

What Happened:

Over the past 30 days, several disruptions were caused by insufficient testing before releasing new features or updates. We’re refining our testing processes to catch potential issues before they affect your experience.

Increased platform demand over the last quarter has also contributed to these interruptions. We’re improving our capacity planning and system optimization to handle higher loads more effectively.

Steps We’re Taking:

Immediate Actions:

We’re prioritizing improvements to our testing environments and bolstering capacity planning to better manage traffic surges, particularly as we gear up for Black Friday.

Long-Term Investments:

We’re implementing advanced testing infrastructure to ensure our platform remains seamless and stable, even during peak periods.

We understand how vital stability is for your business, especially during high-traffic events, and we’re committed to delivering the reliable service you expect from Gorgias. Thank you for your continued trust and patience as we work through these improvements.

Posted Oct 24, 2024 - 11:42 PDT

Resolved
In October we experienced an increase in service disruptions related to different components to the system. Please view the post-mortem attached.
Posted Oct 18, 2024 - 09:00 PDT