Emails forwarded by Outlook mailboxes not coming to Gorgias

Incident Report for Gorgias

Resolved

This incident has been resolved.
Posted May 27, 2021 - 07:52 UTC

Investigating

Forwarded emails from Outlook mailboxes may not come to Gorgias due to ongoing incident on Microsoft side.
https://twitter.com/MSFT365Status/status/1397500708228902914
Posted May 26, 2021 - 13:25 UTC
This incident affected: Helpdesk Integrations (Email).